Cura-packaging/Cura/patches/02-exclude-fonts.patch
Thomas Karl Pietrowski 558d58255d Cura: Applying 02-exclude-fonts.patch
Signed-off-by: Thomas Karl Pietrowski <thopiekar@gmail.com> (github: thopiekar)
2018-01-23 13:11:39 +01:00

18 lines
635 B
Diff

Author: Gregor Riepl <onitake@gmail.com>
Description: Fonts should be packaged separately.
This patch excludes the installation of Open Sans,
so a system version is picked up instead.
A dependency on fonts-open-sans was added to debian/control.
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,8 @@
find_package(PythonInterp 3.5.0 REQUIRED)
install(DIRECTORY resources
- DESTINATION ${CMAKE_INSTALL_DATADIR}/cura)
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/cura
+ PATTERN resources/themes/cura-light/fonts EXCLUDE)
install(DIRECTORY plugins
DESTINATION lib/cura)
if(NOT APPLE AND NOT WIN32)